Dynamic Product Search

Smart Energy Management for Marine and Off Grid

0$0.00
No products in the cart.

REC and WS500 User Forum

Please or Register to create posts and topics.

Unable to connect to REC Active (Error 1073807343)

Hi

I'm having some issues with connecting to the REC Active

I'm running Windows 10.

When starting the BMS Control software  (as an Admin) I get an Error -1073807343 message (See Error message)

When I press continue I get a message "Reading BMS Configuration" This seems to just hang. Escaping, I then go to "Program", "Options" where I get this pop-up (See Set Com Properties).

The selection for the Com Port is prefilled with a number <65535>, clicking to select a COM port, I get an empty box.

I've seen two other posts with this same problem, but both times the problem seem to have either fixed itself, or the suggested solution does not help me.

My REC Active is running (green LED, and connecting the BT module to the RS485 port, I can connect and read the battery voltages and temps)

It might have something to do with my COM port Windows tells me "Windows cannot determine the settings for this device", to which Microsoft suggests I configure the port manually.

Is there info available to do this manual config? Any help will be appreciated.

Pete

 

Uploaded files:
  • Error-message.PNG
  • Set-Com-Properties.PNG

Before connecting in the REC software first check or the comport shows in windows "device manager".

Check comport number here and connect in REC software to correct comport.

If not in device manager REC program will not work.
Most probably your problem is with driver in windows.
Hopes this helps in the right direction for troubleshooting.
Ben

As Ben mentioned this is a Windows driver issue.  The interface cable has an FTDI chipset to convert the USB to RS485 and 99% of Windows PCs will automatically install the driver, but if yours did not you can grab it from the FTDI website.

Here is the link to the website page:  https://ftdichip.com/Drivers/vcp-drivers/

And this is the link to actually driver download as of the writing of this post.:  https://ftdichip.com/wp-content/uploads/2021/08/CDM212364_Setup.zip

And there is a bit about this on the PC software setup video here:  https://www.youtube.com/watch?v=3kXbDFux2pU

Hope this helps,

 

Rick

Hi Rick

Thanks for the info.

I installed the driver's (on two separate Windows 10 PC's) but still have no luck.

There is no response/recognition when I plug the USB cable into either machine.

Might I have a dead USB to 485 cable?

Also, (Ben mentioned this) neither of my machines shows any COM ports in Device Manager.

I've tried the installation of the drivers both with no COM port in the list, and also by creating manually (installing legacy hardware) a COM port. (When I install the COM port manually, Windows shows an error on the COM port.

Same result - no luck

I also have a new Windows Surface laptop (Equipped with an ARM64 CPU) that has the the correct ports, but installing the REC software crashed the machine - I presume its CPU related)

Any other ideas I can check?

Thanks

Pieter

Open device manager.

After that plug in device.

You should get one new line in device manager.

If not under comports, maybe on another place.

Reconfigure this line.

If still not work, post screenshot from device manager with the device plugged in.

Ben

First of all, thanks for the help!

Here's the screenshots from the device manager.

First one is with no COM ports listed. Plugging in the USB cable makes no difference - same view with or without the USB cable plugged in.

Second shot I manually added COM port. Again no change between plugged in or not.

 

I watched the video again how to make the connection. In the video you can clearly hear the audio acknowledge sound when the USB is plugged in - for me there is no acknowledgement at all that there is something connected to the USB port.

 

Uploaded files:
  • Device-Manager-No-change-when-plugging-in.png
  • Device-Manager-Now-with-manually-added-COM-port-still-No-change-when-plugging-in.png

There is a difference though now when I run the BMS software.

I don't get error 1073807343 anymore, but rather this new 7346 message. End result is still the same - No COM port to select in the SW

 

Uploaded files:
  • New-error-message.png

From device manager screenshot is a fault at com 7.

This is a windows comport fault, you need to solve this.

 

If you disconnect the REC device, does this com 7 disappear?

Or is there another device connected?

Click on all subpages from com 7 and post them.

After every change, it can help to restart your windows completely.

Also look for changes in device manager under the other tabs.

You mention when you plug in the usb cable you hear a bleep, this means windows recognize something, but adres it not as a comport, but something else.

A typical windows error that happens sometimes.

Ben

Ben, the error is on the manually created COM port. There is no difference to the view if I plug in the USB or not.

And no, the COM port doesn't disappear when I unplug the USB.

The two version of the device manager I posted is one without the manually created port and one with. The two pages look exactly the same with or without the USB plugged in.

Ive had every every sub-page open while I plugged in the USB - There is NO activity or change when I do.

 

 

I added my previous post, please read that again, maybe some tips help you.

Restart windows. Plug in usb again, do you hear any bleep or nothing?

Not any change in device manager?

 

You sure the bms is powered ON?

 

Ben

Nothing - no beep, no change in the device manager.

Yes the BMS is on - I've tried every permutation with it on or off when I plug in the USB.

To confirm that the 485 works, I connected the BT module, and I can read the cell voltages and temps on my phone.

 

  • If the rs485 is working,  then the REC is all ok.

Try another usb cable.

And as mention before, first have the comport showing corretly in device manager.  No reason to start software before that shows correctly.

You can plugin the usb cable with NO REC connected at all, there should be a new comport showing in device manager.

Start with connecting cable only!!

And reboot windows!!

Ben

I am quite convinced that the cable is dead. There's no indication on three different machines when plugging it in. I'll see how quick I can get one shipped.

Again, thanks for the help!

 

Pete

Hey Pete,  it is starting to sound like you have a bad 485 cable.  I would grab a new one at this point.  We sell them as part of the PC Windows software or you can go back to where you got yours originally.

It looks like we have lots in stock.

Here is the link:  https://www.offgridsoftwaresolutions.com/product/rec-pc-software/

 

@officeogss

Ha!

One DOA factory original USB cable. I just got my new OffGrid cable, connected it and lo and behold - off to the races!

 

SHARE YOUR CART