Rated 4.9 out of 5

Customer Reviews

REC and WS500 User Forum

Please or Register to create posts and topics.

STM Device in DFU Mode - Hanging (SOLVED)

I'm currently using a MSI workstation (PC) with Windows 10 64bit.

An important note is this laptop only has USB3.0 ports and one USB-C.

 

What I downloaded from Wakespeed website:

Drivers

Universal Configuration Utility

Version 2.5.0 (beta)

CPE #8 Generic LiFeP04

 

Installed the drivers, copied the Version 2.5.0 DFU file and the CPE #8 Generic LiFeP04 TXT file to the Universal Configuration Utility folder. Note, only have one copy of a TXT file and one copy of a DFU file in the Universal Configuration Utility folder. Then finally ran the ~~ UPDATE ~~ .bat.

 

Now this is where the fun begins..

The on-screen instructions are self explanatory and everything seems like its working but taking forever..

Target 00: - Upgrading - Erase Phase (70)... Duration 21:43:22

YES THAT'S 21+ HOURS!! leaving it overnight and hangs up during the next Upgrading - Downloading Phase (28) @ approx 35hrs of Upgrading.  (I knew something was wrong when it took longer than 1 minute but figured I would leave it).

Well after calling it quits due to unit "hanging" and closing the Command Prompt the WS500 LED no longer lights up. I had to open Device Manager to see the USB devices (tick the view, show hidden devices option) and look for STM Device in DFU Mode. When using the update batch file it will ask to hold down the unit for 5 seconds, sometimes it appears it doesn't work as the program will exit saying no STM Device Found. Just make sure it isn't "shaded" in the Device Manager in the Universal Serial Bus Controllers.

 

After hours of looking through forums with issues using ST Microelectronics DFU firmware updates there were multiple sites that said the issue with firmware updates going "very, very, very, slow" is with USB3.0 and the general consensus was to use a USB2.0 hub. This isn't a WS500 issue but a compatibility issue with USB3.0 and ST Microelectronics FYI.

 

Well I went to a local "cheap" electronics store with off-brand imported junk and found a USB2.0 hub and it worked!!

Drivers were already installed, files still in the Utility folder so plugged in the USB2.0 hub and ran the update batch file.

Within 10 seconds the entire process was complete and the unit LED was alive again!

(After the unit hung up and I terminated the process the LED didn't light up and I though it was bricked..)

 

I hope someone finds this useful!

Uploaded files:
  • Capture.PNG
SHARE YOUR CART