Dynamic Product Search

Smart Energy Management for Marine and Off Grid

0$0.00

No products in the cart.

REC and WS500 User Forum

Please or Register to create posts and topics.

REC BMS WiFi Module firmware update

REC has just released version 1.5.1 firmware for the REC BMS Wi-Fi module.

User manual and firmware is available here.

https://rec-bms-na.com/downloads/#7-12-wpfd-rec-wi-fi-module

Folks, hold off on uploading and installing this WiFi firmware update for a couple of days.  I made the mistake of just passing this on without having fully tested it myself and it seems we have a few issues.

I will be getting these resolved asap and update this post when I am happy with it.

Thanks for your understanding!

Adam Sherman has reacted to this post.
Adam Sherman

Does REC post release notes or change logs for their software?

Firmware update is now ready to go.  You may find it a bit confusing so we did up a quick video too.  No release notes though.

download firmware update here:    https://rec-bms-na.com/downloads/#7-12-wpfd-rec-wi-fi-module

view the video here:                        https://rec-bms-na.com/tutorials/

Adam Sherman has reacted to this post.
Adam Sherman

Hi @rick_tech_support,

I just pulled up my WiFi module and see that it is at firmware v1.1 (HW:1.0 SW:1.1), so I want to update it. However, when I upload the update.bin file, I get an error: "Update file not found!" Here is a screenshot of this result:

Any ideas?

Thanks,

A.

Seems like you are trying to install the spiffs file first.  I found it would work if the update file goes first.

If you are following the process correctly and still have issues you will need to get in touch with head office.  I believe there is a manual install process you can use, but we have not had any experience with it as yet.

You can contact them at info@rec-bms.com if you are still stuck and they should be able to help you out.

I will download the file again and check, but I'm quite sure I started with the update file. Maybe I'll restart the module, then try again…

A.

  1. I tried again, got the same error
  2. Restarted the module
  3. Loaded the Firmware page and noticed that the SW was now at 1.5.1 (??)
  4. Uploaded update.bin, no error this time
  5. Uploaded spiffs.bin, no error
  6. Restarted the module again
  7. Everything is good on 1.5.1

Then I changed the IP configuration and it worked quite beautifully.

I read that it works already.

Or alternatively, if you can remove the SD card from the module and plug it into your computer, you can just copy both files onto the card and the module should update directly.

Unpower the module when take out the sd card. Format card to fat32 before copy the 2 files on it.

If update fails always try to unpower the

Module for 1 minute and connect power again.

Glad you got it running and thanks Ben.  I was 90% sure that was the backup workaround fix but did not want to recommend something I hadn't tried or confirmed yet.  Appreciate the input!

I attempted the update and it looked like it had worked, but appears to have corrupted the SD card. I'm getting a "PROBLEM WITH SD CARD, LOGGING IS DISABLED." I've  emailed the head office for input, but may try to build a new SD card from scratch and then loading those files.

Thanks for the update.

You have to be careful to let it go through the full update after re-powering and wait a good 10 minutes for it to do its stuff before pressing the reset or disconnecting it.  Not sure if that was your problem, but good idea regardless. 🙂

Please let us know how you make out so we can share it.

 

Thanks -- good input. I wasn't able to recover the original SD card, but formatting a new card and moving the files there appears to have resolved the issue.

I did the sd card update methode a few times.

No problem, it is updated in a very short time.

Always better todo a format first, this way older backup files are deleted.

If you need them, store them before format.

Very uncommon that a sd card is damaged.

SHARE YOUR CART