Dynamic Product Search

Smart Energy Management for Marine and Off Grid

0$0.00

No products in the cart.

REC and WS500 User Forum

Please or Register to create posts and topics.

Can Bus connection to SI-6048

I'm trying to get the REC BMS to talk to the SI and I get a  communication error on the SMA like it does not recognize the communication.  I assume I don't have it connected correctly.  I am seeing the BMS on the laptop software and have it configured.  Also, there were 2 SMA choices in a drop down config menu of the Q.  I am unclear which to choose.  Any guidance would be appreciated.. I have attached a diagram of the equipment

Uploaded files:
  • sma-data.jpg

My first thought would be to verify they are both using the same CANBus speed.  Type in CANF? in the BMS communications window of the PC software and press query to get the REC speed, and compare that to your inverter settings.

Second would be to verify you have a 120 ohm terminating resistor installed at each end of your network

Thanks Rick.  I will try that tomorrow at site.  How do I connect it with the Midnite solar connected as shown or do I use one of the SMA In/Out ports on the right?

 

In the manuals I could find for the Sunny, there was no details provided.

Based on my experience working with other products, if it were me I would connect the REC BMS CANbus cable to the SMA In Port and put your 120 ohm terminator on the SMA out Port, but I can not confirm this.

bob has reacted to this post.
bob

When I enter CANF?  I get the following error:

Error 65 occurred at Serial Read

LabView: Serial port timeout:  bytes not received at serial port

===================

Labview: The network connection is already established

If I change the baud setting in the options menu, I lose connection with the Q

Bob Shaw

it sounds like you have the wrong "send to" address in your BMS command window.  It typically defaults to 100 and likely should be 1 for a Q BMS or 2 for an Active BMS.

 

Remember that you can have many REC BMSs connected together for large packs and the PC tool allows you to access any BMS on the network through any connected device.

I set it to one and got a new message in reply box.  ERROR 1.   Getting closer

Uploaded files:
  • PXL_20211124_235328628.jpg

make sure your CTRL address is set to zero (0) in File-> Options

make sure you use CAPS

click the "Query" button to check values  like CANF ?   (Query)

click the "Send" button to set values like CANF 1   (Send)

That should get it working for you.

CTRL=O,   Caps are on

It appears you have a space between CANF  and ?  Tried it both ways then hit Query with same ERROR 1 response .

Showing live data from the battery. For trouble shooting purposes I have removed the Midnite Solar connection and have the REC plugged in the CAN IN  with a terminator in CAN Out.

Sunny Islands for sale cheap!

Happy Thanksgiving!

 

Bob,

I was able to replicate your error but only by using small letters then pressing "Enter".

The error remained until I gave it a new value using CANF 1 (Send)

Then I tried CANF ? (Query) and it now replies with a 1.

If no luck, then maybe restart your app and the BMS and try again.

Hope this helps,

Rick

SHARE YOUR CART